You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-im/yowsup/files/yowsup-2.5.7-fix-install-pa...

29 lines
1006 B

Description: Fixes wrong installation of mime.types file.
Author: Josue Ortega <josue@debian.org>
Last-Update: 2016-09-04
--- a/setup.py
+++ b/setup.py
@@ -33,7 +33,7 @@
#long_description=long_description,
packages= find_packages(),
include_package_data=True,
- data_files = [('yowsup/common', ['yowsup/common/mime.types'])],
+ #data_files = [('yowsup/common', ['yowsup/common/mime.types'])],
platforms='any',
#test_suite='',
classifiers = [
--- a/yowsup/common/tools.py
+++ b/yowsup/common/tools.py
@@ -150,7 +150,9 @@
return preview
class MimeTools:
- MIME_FILE = os.path.join(os.path.dirname(__file__), 'mime.types')
+ # Replaces mime.types path for the debian path installation
+ # MIME_FILE = os.path.join(os.path.dirname(__file__), 'mime.types')
+ MIME_FILE = os.path.join('/usr/share/yowsup/common', 'mime.types')
mimetypes.init() # Load default mime.types
try:
mimetypes.init([MIME_FILE]) # Append whatsapp mime.types