You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-misc/fslurp/files/fslurp-2.1.4-makefile.patch

48 lines
1017 B

--- fslurp-2.1.4/Makefile
+++ fslurp-2.1.4/Makefile
@@ -51,35 +51,35 @@
INCLUDES = fslurp.h fronius.h
SIMINCLUDES = simulator.h
-DEBUGFLAGS = -g
-CFLAGS = -c -Wall $(DEBUGFLAGS)
+#DEBUGFLAGS = -g
+CFLAGS += -c -Wall $(DEBUGFLAGS)
-LDFLAGS = -lm
+LIBS = -lm
VERSION := fslurp-$(shell tail -1 version)
all: $(TARGETS)
fslurp: $(FSLURP_OBJS)
- $(CC) $(LDFLAGS) $^ -o $@
+ $(CC) $(LDFLAGS) $^ -o $@ $(LIBS)
simSolarNet2i1s: \
$(SIMSOLARNET2I1S_OBJS)
- $(CC) $(LDFLAGS) $^ -o $@
+ $(CC) $(LDFLAGS) $^ -o $@ $(LIBS)
simSolarNet1i0s: \
$(SIMSOLARNET1I0S_OBJS)
- $(CC) $(LDFLAGS) $^ -o $@
+ $(CC) $(LDFLAGS) $^ -o $@ $(LIBS)
simSolarNet0i0s: \
$(SIMSOLARNET0I0S_OBJS)
- $(CC) $(LDFLAGS) $^ -o $@
+ $(CC) $(LDFLAGS) $^ -o $@ $(LIBS)
simIFCEasy: $(SIMIFCEASY_OBJS)
- $(CC) $(LDFLAGS) $^ -o $@
+ $(CC) $(LDFLAGS) $^ -o $@ $(LIBS)
sim422IGTL: $(SIM422IGTL_OBJS)
- $(CC) $(LDFLAGS) $^ -o $@
+ $(CC) $(LDFLAGS) $^ -o $@ $(LIBS)
test: $(TARGETS) clean
./testcase.sh