You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-libs/libbpf/files/libbpf-0.0.5-paths.patch

39 lines
997 B

diff --git a/Makefile b/Makefile
index 6992fbf..cefc77a 100644
--- a/Makefile
+++ b/Makefile
@@ -64,7 +64,7 @@ endif
PREFIX ?= /usr
LIBDIR ?= $(PREFIX)/$(LIBSUBDIR)
INCLUDEDIR ?= $(PREFIX)/include
-UAPIDIR ?= $(PREFIX)/include
+UAPIDIR ?= $(PREFIX)/include/bpf/uapi
all: $(STATIC_LIBS) $(SHARED_LIBS) $(PC_FILE)
@@ -85,6 +85,7 @@ $(OBJDIR)/libbpf.so.$(LIBBPF_VERSION): $(SHARED_OBJS)
$(OBJDIR)/libbpf.pc:
sed -e "s|@PREFIX@|$(PREFIX)|" \
-e "s|@LIBDIR@|$(LIBDIR)|" \
+ -e "s|@UAPIDIR@|$(UAPIDIR)|" \
-e "s|@VERSION@|$(LIBBPF_VERSION)|" \
< libbpf.pc.template > $@
diff --git a/libbpf.pc.template b/libbpf.pc.template
index ac17fce..6d385d9 100644
--- a/libbpf.pc.template
+++ b/libbpf.pc.template
@@ -3,10 +3,11 @@
prefix=@PREFIX@
libdir=@LIBDIR@
includedir=${prefix}/include
+uapidir=@UAPIDIR@
Name: libbpf
Description: BPF library
Version: @VERSION@
Libs: -L${libdir} -lbpf
Requires.private: libelf
-Cflags: -I${includedir}
+Cflags: -I${includedir} -I${uapidir}