You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-libs/libbpf/files/libbpf-0.20190404-makefile....

17 lines
452 B

diff --git a/Makefile b/src/Makefile
index 35b4818..c034531 100644
--- a/Makefile
+++ b/Makefile
@@ -36,7 +36,10 @@ OBJDIR ?= .
OBJS := $(addprefix $(OBJDIR)/,bpf.o btf.o libbpf.o libbpf_errno.o netlink.o \
nlattr.o str_error.o libbpf_probes.o bpf_prog_linfo.o xsk.o)
-LIBS := $(OBJDIR)/libbpf.a
+ifdef BUILD_STATIC
+ LIBS := $(OBJDIR)/libbpf.a
+endif
+
ifndef BUILD_STATIC_ONLY
LIBS += $(OBJDIR)/libbpf.so \
$(OBJDIR)/libbpf.so.$(VERSION) \