You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-libs/json-c/files/json-c-0.10-headers.patch

28 lines
626 B

--- json-c-0.10/json.pc.in
+++ json-c-0.10/json.pc.in
@@ -8,4 +8,4 @@
Version: @VERSION@
Requires:
Libs: -L${libdir} -ljson
-Cflags: -I${includedir}/json
+Cflags: -I${includedir}/json-c
--- json-c-0.10/Makefile.am
+++ json-c-0.10/Makefile.am
@@ -8,7 +8,7 @@
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = json.pc
-libjsonincludedir = $(includedir)/json
+libjsonincludedir = $(includedir)/json-c
libjsoninclude_HEADERS = \
arraylist.h \
bits.h \
@@ -17,6 +17,7 @@
json_config.h \
json_inttypes.h \
json_object.h \
+ json_object_iterator.h \
json_object_private.h \
json_tokener.h \
json_util.h \