You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sys-apps/sandbox/files/sandbox-2.6-gcc-5.patch

14 lines
455 B

fix building w/gcc-5
--- a/libsandbox/Makefile.in
+++ b/libsandbox/Makefile.in
@@ -68,7 +68,7 @@ sb_nr.h: symbols.h $(SB_NR_FILE)
TRACE_MAKE_HEADER = \
$(SB_AWK) $(GEN_TRACE_SCRIPT) -v MODE=gen | \
- $(COMPILE) -E -include $(top_srcdir)/headers.h - $$f | \
+ $(COMPILE) -E -P -include $(top_srcdir)/headers.h - $$f | \
$(SB_AWK) $(GEN_TRACE_SCRIPT) -v syscall_prefix=$$t > $$header
trace_syscalls.h: $(GEN_TRACE_SCRIPT) Makefile
if SB_SCHIZO