You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sys-fs/quotatool/files/quotatool-1.4.13-ldflags.patch

24 lines
553 B

--- quotatool-1.4.13/local.mk.in
+++ quotatool-1.4.13/local.mk.in
@@ -17,7 +17,8 @@
CC := @CC@
CFLAGS := @CFLAGS@
-CPPFLAGS = $(inc) @DEFS@
+LDFLAGS := @LDFLAGS@
+CPPFLAGS = @CPPFLAGS@ $(inc) @DEFS@
INSTALL := @INSTALL@
--- quotatool-1.4.13/Makefile
+++ quotatool-1.4.13/Makefile
@@ -58,7 +58,7 @@
# compile the program (and the objects)
all: $(prog)
$(prog): $(objs)
- $(CC) -o $(prog) $(objs) $(libs) $(CFLAGS)
+ $(CC) $(CFLAGS) $(LDFLAGS) -o $(prog) $(objs) $(libs)