You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-embedded/smdk-dltool/files/smdk-dltool-0.20-build.patch

21 lines
364 B

respect env build settings
--- a/Makefile
+++ b/Makefile
@@ -7,8 +7,13 @@
.PHONY: clean
-dltool: dltool.c
- $(CC) -O2 -Wall -g -lusb -o smdk-usbdl dltool.c
+CFLAGS ?= -O2 -g
+CFLAGS += -Wall
+PKG_CONFIG ?= pkg-config
+CPPFLAGS += $(shell $(PKG_CONFIG) --cflags libusb)
+LDLIBS = $(shell $(PKG_CONFIG) --libs libusb)
+
+all: dltool
clean:
-rm smdk-usbdl