You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-emulation/ganeti-htools/files/ganeti-htools-0.2.8-use-QC-...

15 lines
526 B

diff --git a/Makefile b/Makefile
index 5e189fc..bfdf175 100644
--- a/Makefile
+++ b/Makefile
@@ -20,7 +20,8 @@ $(HALLPROGS): %: %.hs Ganeti/HTools/Version.hs $(HSRCS) Makefile
test live-test: HEXTRA=-fhpc -Wwarn -fno-warn-missing-signatures \
-fno-warn-monomorphism-restriction -fno-warn-orphans \
- -fno-warn-missing-methods -fno-warn-unused-imports
+ -fno-warn-missing-methods -fno-warn-unused-imports \
+ -package $(shell ghc-pkg list | sed -n '/ QuickCheck-1./p')
$(DOCS) : %.html : %
rst2html -v --strict $< $@