You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-libs/xxhash/files/xxhash-0.6.5-compile-xxhash...

29 lines
746 B

--- a/Makefile
+++ b/Makefile
@@ -82,7 +82,7 @@
all: lib xxhsum xxhsum_inlinedXXH
xxhsum32: CFLAGS += -m32
-xxhsum xxhsum32: xxhash.c xxhsum.c
+xxhsum xxhsum32: xxhash.o xxhsum.c
$(CC) $(FLAGS) $^ -o $@$(EXT)
.PHONY: xxhsum_and_links
@@ -105,12 +105,12 @@
ifeq (,$(filter Windows%,$(OS)))
$(LIBXXH): LDFLAGS += -fPIC
endif
-$(LIBXXH): xxhash.c
+$(LIBXXH): xxhash.o
@echo compiling dynamic library $(LIBVER)
- @$(CC) $(FLAGS) $^ $(LDFLAGS) $(SONAME_FLAGS) -o $@
+ $(CC) $(FLAGS) $^ $(LDFLAGS) $(SONAME_FLAGS) -o $@
@echo creating versioned links
- @ln -sf $@ libxxhash.$(SHARED_EXT_MAJOR)
- @ln -sf $@ libxxhash.$(SHARED_EXT)
+ ln -sf $@ libxxhash.$(SHARED_EXT_MAJOR)
+ ln -sf $@ libxxhash.$(SHARED_EXT)
libxxhash : $(LIBXXH)