You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-shells/hstr/files/hstr-2.0-fix-ncurses-config...

78 lines
2.4 KiB

--- a/configure.ac
+++ b/configure.ac
@@ -47,39 +47,33 @@ then
fi
# PKG_CHECK_MODULES macro is NOT used to avoid confusing syntax errors in case that pkg-config is NOT installed
-AC_CHECK_LIB(ncursesw, killwchar, [],
-[
- AC_CHECK_LIB(ncurses, killwchar, [],
- [
- AC_SUBST([NCURSESW_CFLAGS])
- AC_SUBST([NCURSESW_LIBS])
- if pkg-config --exists ncursesw
- then
- AC_MSG_NOTICE([Module ncursesw found])
- NCURSESW_CFLAGS=`pkg-config --cflags ncursesw`
- NCURSESW_LIBS=`pkg-config --libs ncursesw`
- else
- if pkg-config --exists ncurses
- then
- AC_MSG_NOTICE([Module ncurses found])
- NCURSESW_CFLAGS=`pkg-config --cflags ncursesw`
- NCURSESW_LIBS=`pkg-config --libs ncurses`
- else
- AS_CASE([$host_os],
- [darwin*],
- [
- AC_CHECK_LIB(ncurses, killwchar, [], [AC_MSG_ERROR([Could not find ncurses library])])
- AC_CHECK_HEADER(curses.h)
- ],
- [
- AC_CHECK_LIB(ncursesw, killwchar, [], [AC_MSG_ERROR([Could not find ncursesw library])])
- AC_CHECK_HEADER(ncursesw/curses.h)
- ]
- )
- fi
- fi
- ]) # FAIL of ncurses
-]) # FAIL of ncursesw
+AC_SUBST([NCURSESW_CFLAGS])
+AC_SUBST([NCURSESW_LIBS])
+if pkg-config --exists ncursesw
+then
+ AC_MSG_NOTICE([Module ncursesw found])
+ NCURSESW_CFLAGS=`${PKG_CONFIG} --cflags ncursesw`
+ NCURSESW_LIBS=`${PKG_CONFIG} --libs ncursesw`
+else
+ if ${PKG_CONFIG} --exists ncurses
+ then
+ AC_MSG_NOTICE([Module ncurses found])
+ NCURSESW_CFLAGS=`${PKG_CONFIG} --cflags ncursesw`
+ NCURSESW_LIBS=`${PKG_CONFIG} --libs ncurses`
+ else
+ AS_CASE([$host_os],
+ [darwin*],
+ [
+ AC_CHECK_LIB(ncurses, killwchar, [], [AC_MSG_ERROR([Could not find ncurses library])])
+ AC_CHECK_HEADER(curses.h)
+ ],
+ [
+ AC_CHECK_LIB(ncursesw, killwchar, [], [AC_MSG_ERROR([Could not find ncursesw library])])
+ AC_CHECK_HEADER(ncursesw/curses.h)
+ ]
+ )
+ fi
+fi
# Checks for libraries.
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -37,4 +37,4 @@ hstr_SOURCES = \
install-exec-hook:
ln $(DESTDIR)$(bindir)/hstr$(EXEEXT) $(DESTDIR)$(bindir)/hh$(EXEEXT)
-hstr_LDADD = $(NCURSES_LIBS)
+hstr_LDADD = $(NCURSESW_LIBS)