You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-python/spyder/files/spyder-4.2.1-build.patch

37 lines
1.2 KiB

diff --git a/setup.py b/setup.py
index 0c47210..20b95c0 100644
--- a/setup.py
+++ b/setup.py
@@ -97,21 +97,6 @@ def get_packages():
return packages
-#==============================================================================
-# Make Linux detect Spyder desktop file
-#==============================================================================
-class MyInstallData(install_data):
- def run(self):
- install_data.run(self)
- if sys.platform.startswith('linux'):
- try:
- subprocess.call(['update-desktop-database'])
- except:
- print("ERROR: unable to update desktop database",
- file=sys.stderr)
-CMDCLASS = {'install_data': MyInstallData}
-
-
#==============================================================================
# Main scripts
#==============================================================================
@@ -177,8 +162,7 @@ def run(self):
'Intended Audience :: Developers',
'Topic :: Scientific/Engineering',
'Topic :: Software Development :: Widget Sets'
- ],
- cmdclass=CMDCLASS)
+ ])
#==============================================================================