You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-ros/rviz/files/yamlcpp.patch

15 lines
435 B

Index: rviz-1.14.8/src/rviz/CMakeLists.txt
===================================================================
--- rviz-1.14.8.orig/src/rviz/CMakeLists.txt
+++ rviz-1.14.8/src/rviz/CMakeLists.txt
@@ -1,4 +1,8 @@
-find_package(yaml-cpp REQUIRED)
+find_package(PkgConfig REQUIRED)
+pkg_check_modules(YAML_CPP yaml-cpp)
+if(NOT YAML_CPP_FOUND)
+ find_package(yaml-cpp REQUIRED)
+endif()
include_directories(${YAML_CPP_INCLUDE_DIR})