You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/games-mud/gnome-mud/files/0.11.2-gst1.patch

43 lines
1.6 KiB

From 15c37855ab3559efaeffcef651c98ed971ae84bb Mon Sep 17 00:00:00 2001
From: Steven Jackson
Date: Wed, 19 Apr 2017 20:02:57 +0100
Subject: [PATCH] gstreamer: Upgrade to 1.0 from 0.10
---
configure.ac | 6 +++---
gnome-mud.spec.in | 4 ++--
2 files changed, 5 insertions(+), 5 deletions(-)
diff --git a/configure.ac b/configure.ac
index 50c4c81..125b054 100644
--- a/configure.ac
+++ b/configure.ac
@@ -76,7 +76,7 @@ LIBGNET_REQUIRED=0.22
VTE_REQUIRED=0.11.00
PCRE_REQUIRED=6.0.0
GCONF_REQUIRED=0.20
-GSTREAMER_REQUIRED=0.10
+GSTREAMER_REQUIRED=1.0
PKG_CHECK_MODULES(GMUD, gtk+-2.0 >= $GTK_REQUIRED vte >= $VTE_REQUIRED libglade-2.0 >= $LIBGLADE_REQUIRED libpcre >= $PCRE_REQUIRED gmodule-2.0 >= $GMODULE_REQUIRED gnet-2.0 >= $LIBGNET_REQUIRED gconf-2.0 >= $GCONF_REQUIRED)
AC_SUBST(GMUD_CFLAGS)
@@ -114,14 +114,14 @@ AC_ARG_ENABLE(gstreamer,
[Enable GStreamer used for MSP (Mud Sound Protocol) Default=auto]),,
enable_gstreamer=auto)
if test "x$enable_gstreamer" != "xno"; then
- PKG_CHECK_EXISTS(gstreamer-0.10, have_gst=yes, have_gst=no)
+ PKG_CHECK_EXISTS(gstreamer-1.0, have_gst=yes, have_gst=no)
if test "x$have_gst" = "xno" -a "x$enable_gstreamer" = "xyes"; then
AC_MSG_ERROR([Gstreamer support explicitly requested but libgstreamer was not found])
fi
if test "x$have_gst" = "xyes"; then
AC_DEFINE(ENABLE_GST, 1, [Define if GStreamer should be enabled])
enable_gstreamer=yes
- PKG_CHECK_MODULES(MSP, gstreamer-0.10 >= $GSTREAMER_REQUIRED)
+ PKG_CHECK_MODULES(MSP, gstreamer-1.0 >= $GSTREAMER_REQUIRED)
fi
fi
AM_CONDITIONAL(USE_GSTREAMER, test "x$enable_gstreamer" = xyes)
--
2.10.2