You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-sound/rcenter/files/rcenter-0.6.2-makefile.patch

22 lines
549 B

--- a/Makefile
+++ b/Makefile
@@ -1,6 +1,4 @@
ALLFILES = *.c *.h Makefile LICENSE HISTORY README config
-CC = gcc
-CFLAGS = -O2
BINARIES = rcenter
PREFIX= /usr/local
@@ -19,9 +17,9 @@
main.o : main.c
rcenter : main.o lowlevel.o handler.o button.o
- $(CC) $(CFLAGS) -o rcenter $^ -lpthread
+ $(CC) $(LDFLAGS) -o rcenter $^ -lpthread
-projname := $(shell awk '/RCENTER_VERSION/ { print $$3 }' version.h )
+projname := $(shell gawk '/RCENTER_VERSION/ { print $$3 }' version.h )
install: rcenter
install -D rcenter $(PREFIX)/bin/rcenter