You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sci-biology/exonerate/files/exonerate-2.2.0-asneeded.patch

16 lines
362 B

Fix build with --as-needed
https://bugs.gentoo.org/268094
--- a/configure.in
+++ b/configure.in
@@ -289,7 +289,7 @@
if test "$enable_pthreads" = yes; then
echo "Using PTHREADS"
CFLAGS="$CFLAGS -DUSE_PTHREADS"
- LDFLAGS="$LDFLAGS -lpthread"
+ LIBS="$LIBS -lpthread"
elif test "$enable_pthreads" = no; then
echo "Not using pthreads"
else