You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/www-servers/lighttpd/files/lighttpd-1.4.59-nspr-header...

17 lines
546 B

diff --git a/configure.ac b/configure.ac
index 325a1b4b..3f32daa9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -887,7 +887,10 @@ if test "x$use_nss" = "xyes"; then
NSS_LIBS="-L$WITH_NSS/lib -lnss3"
else
PKG_CHECK_MODULES([NSS],[nss])
- CPPFLAGS="$CPPFLAGS -I/usr/include/nspr4"
+ if test "x$CRYPTO_LIB" = "x"; then
+ PKG_CHECK_MODULES([NSPR],[nspr])
+ CPPFLAGS="$CPPFLAGS $NSPR_CFLAGS"
+ fi
fi
AC_DEFINE([HAVE_NSS_NSS_H], [1], [nss/nss.h])
AC_DEFINE([HAVE_NSS3_NSS_H], [1], [nss3/nss.h])