You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-db/redis/files/redis-6.2.3-ppc-atomic.patch

20 lines
465 B

diff --git a/src/Makefile b/src/Makefile
index 5b2cf1c..9e1239d 100644
--- a/src/Makefile
+++ b/src/Makefile
@@ -87,6 +87,14 @@ FINAL_LIBS=-lm
FINAL_LIBS+=@LUA_LIBS@
DEBUG=-g -ggdb
+ifneq (,$(filter powerpc ppc,$(uname_M)))
+ FINAL_LIBS+=-latomic
+else
+ifneq (,$(findstring ppc,$(uname_M)))
+ FINAL_LIBS+=-latomic
+endif
+endif
+
# Linux ARM32 needs -latomic at linking time
ifneq (,$(findstring armv,$(uname_M)))
FINAL_LIBS+=-latomic