You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-ftp/proftpd/files/proftpd-1.3.6a-fix-libcheck...

29 lines
726 B

Fix test suite detection.
https://github.com/proftpd/proftpd/pull/839
Reported-by: Toralf Förster
Bug: https://bugs.gentoo.org/697782
--- a/configure.in
+++ b/configure.in
@@ -991,7 +991,7 @@ AC_ARG_ENABLE(tests,
[enable unit tests (default=no)])
],
[
- if test "$enableval" != xno ; then
+ if test x"$enableval" != xno ; then
AC_CHECK_HEADERS(check.h)
AC_CHECK_LIB(check, tcase_create,
--- a/configure
+++ b/configure
@@ -20639,7 +20639,7 @@ ENABLE_TESTS="\"\""
# Check whether --enable-tests was given.
if test "${enable_tests+set}" = set; then
enableval=$enable_tests;
- if test "$enableval" != xno ; then
+ if test x"$enableval" != xno ; then
for ac_header in check.h
do