You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-p2p/transmission/files/libsystemd.patch

12 lines
630 B

--- a/configure.ac
+++ b/configure.ac
@@ -245,7 +245,7 @@
[Add support for systemd startup notification (default is autodetected)]),
[USE_SYSTEMD_DAEMON=$withval], [USE_SYSTEMD_DAEMON=auto])
AS_IF([test "x$USE_SYSTEMD_DAEMON" != "xno"], [
- PKG_CHECK_MODULES([SYSTEMD_DAEMON], [libsystemd-daemon],
+ PKG_CHECK_MODULES([SYSTEMD_DAEMON], [libsystemd],
[AC_DEFINE(USE_SYSTEMD_DAEMON,1,[Use systemd startup notification])],
[AS_IF([test "x$USE_SYSTEMD_DAEMON" = "xyes"],
[AC_MSG_ERROR([systemd startup notification support requested, but libsystemd-daemon not found.])]