You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-arch/cpio/files/cpio-2.13-sysmacros-glibc-2...

43 lines
1.4 KiB

--- a/am/ax_compile_check_rettype.m4
+++ b/am/ax_compile_check_rettype.m4
@@ -70,6 +70,9 @@ AC_CACHE_VAL(AC_CV_NAME,
[for ac_type in char short int long "long long" $4
do
AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
+#ifdef HAVE_SYS_SYSMACROS_H
+#include <sys/sysmacros.h>
+#endif
#include <sys/types.h>
$3
]], [[switch (0) case 0: case (sizeof ($1($2)) == sizeof ($ac_type)):;]])], [AC_CV_NAME=$ac_type])
--- a/configure.ac
+++ b/configure.ac
@@ -39,14 +39,11 @@ AC_C_PROTOTYPES
AC_SYS_LARGEFILE
AC_TYPE_SIGNAL
-AC_HEADER_MAJOR
AC_C_CONST
AC_TYPE_UID_T
AC_CHECK_TYPE(gid_t, int)
AC_HEADER_STDC
AC_HEADER_DIRENT
-AC_COMPILE_CHECK_RETTYPE([major], [0])
-AC_COMPILE_CHECK_RETTYPE([minor], [0])
AC_CHECK_FUNCS([fchmod fchown])
# This is needed for mingw build
@@ -67,7 +64,11 @@ AC_ARG_ENABLE(mt,
AM_CONDITIONAL([CPIO_MT_COND], [test "$enable_mt" = yes])
-AC_CHECK_HEADERS([unistd.h stdlib.h string.h fcntl.h pwd.h grp.h sys/io/trioctl.h utmp.h getopt.h locale.h libintl.h sys/wait.h utime.h locale.h process.h sys/ioctl.h])
+AC_CHECK_HEADERS([unistd.h stdlib.h string.h fcntl.h pwd.h grp.h sys/io/trioctl.h utmp.h getopt.h locale.h libintl.h sys/wait.h utime.h locale.h process.h sys/ioctl.h sys/sysmacros.h])
+
+AC_HEADER_MAJOR
+AC_COMPILE_CHECK_RETTYPE([major], [0])
+AC_COMPILE_CHECK_RETTYPE([minor], [0])
AC_CHECK_DECLS([errno, getpwnam, getgrnam, getgrgid, strdup, strerror, getenv, atoi, exit], , , [
#include <stdio.h>