You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-gfx/apngasm/files/apngasm-2.91-makefile.patch

23 lines
585 B

--- apngasm-2.91-src/Makefile
+++ apngasm-2.91-src/Makefile
@@ -1,8 +1,7 @@
PACKAGE = apngasm
CC = gcc
-SRC_DIRS = . 7z zopfli
-CFLAGS = -Wall -pedantic -DFEATURE_7ZIP -DFEATURE_ZOPFLI
-CFLAGS_OPT = -O2
+SRC_DIRS = . 7z
+CFLAGS += -Wall -pedantic
CFLAGS_7Z = -Wno-sign-compare -Wno-reorder -Wno-maybe-uninitialized -Wno-parentheses
LIBS = -lstdc++ -lm -lpng -lz
@@ -16,7 +15,7 @@
all : $(PACKAGE)
$(PACKAGE) : objdirs $(OBJECTS)
- $(CC) -o $@ $(OBJECTS) -s $(LIBS)
+ $(CC) -o $@ $(OBJECTS) $(LDFLAGS) $(LIBS)
objdirs :
mkdir -p $(OBJ_DIRS)