You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-gfx/gif2png/files/gif2png-2.5.12-makefile.patch

43 lines
1.0 KiB

Respect CFLAGS/LDFLAGS/DESTDIR and don't try to run missing tests.
--- gif2png-2.5.12/Makefile
+++ gif2png-2.5.12/Makefile
@@ -2,8 +2,7 @@
VERSION = $(shell sed -n <NEWS '/::/s/^\([^:]*\).*/\1/p' | head -1)
-CFLAGS = -DVERSION=\"$(VERSION)\" -O2
-LDFLAGS = -s
+CFLAGS = -DVERSION=\"$(VERSION)\"
SOURCES = 437_l1.c gif2png.c gifread.c memory.c version.c
OBJECTS = $(SOURCES:.c=.o)
@@ -28,22 +27,19 @@
web2png.1: web2png.xml
xmlto man web2png.xml
-check:
- cd test; make --quiet test
-
clean:
rm -f gif2png *.o gif2png.1 web2png.1
version:
@echo $(VERSION)
-prefix?=/usr
+prefix ?= /usr
install: gif2png gif2png.1 web2png.1
- mkdir -p $(prefix)/bin
- mkdir -p $(prefix)/share/man/man1
- cp gif2png web2png $(prefix)/bin/
- cp gif2png.1 web2png.1 $(prefix)/share/man/man1/
+ mkdir -p $(DESTDIR)$(prefix)/bin
+ mkdir -p $(DESTDIR)$(prefix)/share/man/man1
+ cp gif2png web2png $(DESTDIR)$(prefix)/bin/
+ cp gif2png.1 web2png.1 $(DESTDIR)$(prefix)/share/man/man1/
uninstall:
rm $(prefix)/bin/gif2png $(prefix)/bin/web2png