You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sci-biology/stride/files/stride-20011129-fix-buildsy...

22 lines
807 B

--- a/Makefile
+++ b/Makefile
@@ -1,4 +1,3 @@
-CC = gcc -g
FLAGS = -lm -o
SOURCE = stride.c splitstr.c rdpdb.c initchn.c geometry.c thr2one.c one2thr.c filename.c tolostr.c strutil.c place_h.c hbenergy.c memory.c helix.c sheet.c rdmap.c phipsi.c command.c molscr.c die.c hydrbond.c mergepat.c fillasn.c escape.c p_jrnl.c p_rem.c p_atom.c p_helix.c p_sheet.c p_turn.c p_ssbond.c p_expdta.c p_model.c p_compnd.c report.c nsc.c area.c ssbond.c chk_res.c chk_atom.c turn.c pdbasn.c dssp.c outseq.c chkchain.c elem.c measure.c asngener.c p_endmdl.c stred.c contact_order.c contact_map.c
@@ -7,12 +6,9 @@
BINDIR = .
-.c.o:
- $(CC) -c $< -o $@
-
stride : $(OBJECT)
- $(CC) $(OBJECT) $(FLAGS) $(BINDIR)/stride
+ $(CC) $(LDFLAGS) $(OBJECT) $(FLAGS) $(BINDIR)/stride
$(OBJECT) : stride.h protot.h