You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sys-process/atop/files/atop-2.4.0-build.patch

23 lines
704 B

--- atop-2.4.0/Makefile
+++ atop-2.4.0/Makefile
@@ -33,16 +33,16 @@
atop: atop.o $(ALLMODS) Makefile
$(CC) -c version.c
- $(CC) atop.o $(ALLMODS) -o atop -lncurses -lz -lm -lrt $(LDFLAGS)
+ $(CC) $(CFLAGS) $(LDFLAGS) atop.o $(ALLMODS) -o atop $(shell ${PKG_CONFIG} --libs ncurses) -lz -lm -lrt
atopsar: atop
ln -sf atop atopsar
atopacctd: atopacctd.o netlink.o
- $(CC) atopacctd.o netlink.o -o atopacctd $(LDFLAGS)
+ $(CC) $(CFLAGS) $(LDFLAGS) atopacctd.o netlink.o -o atopacctd
atopconvert: atopconvert.o
- $(CC) atopconvert.o -o atopconvert -lz $(LDFLAGS)
+ $(CC) $(CFLAGS) $(LDFLAGS) atopconvert.o -o atopconvert -lz
netlink.o: netlink.c
$(CC) -I. -Wall -c netlink.c