You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-leechcraft/lc-bittorrent/files/boost-1.50.patch

39 lines
1.3 KiB

diff --git a/src/plugins/bittorrent/CMakeLists.txt b/src/plugins/bittorrent/CMakeLists.txt
index de8a2f9..45d26da 100644
--- a/src/plugins/bittorrent/CMakeLists.txt
+++ b/src/plugins/bittorrent/CMakeLists.txt
@@ -153,7 +153,6 @@ IF (WIN32)
ENDIF (WIN32)
#ADD_DEFINITIONS(-DBOOST_DYN_LINK)
ADD_DEFINITIONS(-DTORRENT_LINKING_SHARED)
-ADD_DEFINITIONS(-DBOOST_FILESYSTEM_VERSION=2) #workaround for building with boost 1.46
#ADD_DEFINITIONS(-D_DLL)
IF (NOT LC_NO_MOC)
QT4_WRAP_CPP (MOC_SRCS ${HEADERS})
diff --git a/src/plugins/bittorrent/torrentmaker.cpp b/src/plugins/bittorrent/torrentmaker.cpp
index 313a6a5..467c4d8 100644
--- a/src/plugins/bittorrent/torrentmaker.cpp
+++ b/src/plugins/bittorrent/torrentmaker.cpp
@@ -40,7 +40,11 @@ namespace LeechCraft
{
bool FileFilter (const boost::filesystem::path& filename)
{
+#if BOOST_FILESYSTEM_VERSION == 2
if (filename.leaf () [0] == '.')
+#else
+ if (filename.leaf ().string () [0] == '.')
+#endif
return false;
QFileInfo fi (QString::fromUtf8 (filename.string ().c_str ()));
if ((fi.isDir () ||
@@ -74,7 +78,9 @@ namespace LeechCraft
return;
}
+#if BOOST_FILESYSTEM_VERSION == 2
boost::filesystem::path::default_name_check (boost::filesystem::no_check);
+#endif
libtorrent::file_storage fs;
#if LIBTORRENT_VERSION_NUM >= 1600