You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/x11-libs/xpyb/files/xpyb-python.patch

13 lines
551 B

--- xpyb-1.3.1/configure.ac.orig 2013-05-21 19:01:51.054962821 +0400
+++ xpyb-1.3.1/configure.ac 2013-05-21 19:05:22.342961464 +0400
@@ -38,7 +38,8 @@
# Find the xcbgen Python package
AC_MSG_CHECKING([for xcb-proto python dir])
-XCBPROTO_XCBPYTHONDIR=`$PKG_CONFIG --variable=pythondir xcb-proto`
+XCBPROTO_XCBPYTHONDIR=`$PYTHON -c 'import xcbgen; from os.path import dirname, abspath, join; \
+ print abspath(join(dirname(xcbgen.[__file__]), ".."))'`
AC_MSG_RESULT($XCBPROTO_XCBPYTHONDIR)
AC_SUBST(XCBPROTO_XCBPYTHONDIR)