66 lines
2.2 KiB
Diff
66 lines
2.2 KiB
Diff
--- lua-5.1.1.orig/Makefile 2006-06-02 12:53:38.000000000 +0200
|
|
+++ lua-5.1.1/Makefile 2006-11-16 02:16:53.000000000 +0100
|
|
@@ -127,3 +127,21 @@
|
|
.PHONY: all $(PLATS) clean test install local none dummy echo pecho lecho newer
|
|
|
|
# (end of Makefile)
|
|
+
|
|
+# Use libtool for binary installs, etc.
|
|
+
|
|
+export V
|
|
+export LIBTOOL = libtool --quiet --tag=CC
|
|
+# See libtool manual about how to set this
|
|
+
|
|
+gentoo_clean:
|
|
+ cd src; $(MAKE) $@
|
|
+
|
|
+gentoo_test: gentoo_linux
|
|
+ test/lua.static test/hello.lua
|
|
+
|
|
+gentoo_install:
|
|
+ mkdir -p $(INSTALL_BIN) $(INSTALL_INC) $(INSTALL_LIB)
|
|
+ cd src; $(LIBTOOL) --mode=install $(INSTALL_EXEC) lua luac $(INSTALL_BIN)
|
|
+ cd src; $(INSTALL_DATA) $(TO_INC) $(INSTALL_INC)
|
|
+ cd src; $(LIBTOOL) --mode=install $(INSTALL_DATA) liblua.la $(INSTALL_LIB)
|
|
--- lua-5.1.1.orig/src/Makefile 2006-03-22 01:41:49.000000000 +0100
|
|
+++ lua-5.1.1/src/Makefile 2006-11-16 02:10:27.000000000 +0100
|
|
@@ -54,1 +54,1 @@
|
|
-$(LUA_T): $(LUA_O) $(LUA_A)
|
|
+origin$(LUA_T): $(LUA_O) $(LUA_A)
|
|
@@ -57,1 +57,1 @@
|
|
-$(LUAC_T): $(LUAC_O) $(LUA_A)
|
|
+origin$(LUAC_T): $(LUAC_O) $(LUA_A)
|
|
@@ -176,3 +176,33 @@
|
|
ltm.h lzio.h lmem.h lopcodes.h lundump.h
|
|
|
|
# (end of Makefile)
|
|
+
|
|
+export LIBTOOL = libtool --quiet --tag=CC
|
|
+export LIB_VERSION = 6:1:1
|
|
+
|
|
+# The following rules use libtool for compiling and linking in order to
|
|
+# provide shared library support.
|
|
+
|
|
+LIB_NAME = liblua.la
|
|
+LIB_OBJS = $(CORE_O:.o=.lo) $(LIB_O:.o=.lo)
|
|
+
|
|
+%.lo %.o: %.c
|
|
+ $(LIBTOOL) --mode=compile $(CC) -c $(CPPFLAGS) $(CFLAGS) -o $@ $<
|
|
+
|
|
+$(LIB_NAME): $(LIB_OBJS)
|
|
+ $(LIBTOOL) --mode=link $(CC) -version-info $(LIB_VERSION) \
|
|
+ -rpath $(RPATH) $(LDFLAGS) -o $(LIB_NAME) $(LIB_OBJS) $(LIB_LIBS)
|
|
+
|
|
+$(LUA_T): $(LUA_O:.o=.lo) $(LIB_NAME)
|
|
+ $(LIBTOOL) --mode=link $(CC) -export-dynamic $(LDFLAGS) -o $@ $(LUA_O:.o=.lo) $(LIB_NAME) $(LUA_LIBS)
|
|
+
|
|
+lua_test: $(LUA_O:.o=.lo) $(LIB_NAME)
|
|
+ $(LIBTOOL) --mode=link $(CC) -static -export-dynamic $(LDFLAGS) -o $@ $(LUA_O:.o=.lo) $(LIB_NAME) $(LUA_LIBS)
|
|
+
|
|
+$(LUAC_T): $(LUAC_O:.o=.lo) $(LIB_NAME)
|
|
+ $(LIBTOOL) --mode=link $(CC) -static $(LDFLAGS) -o $@ $(LUAC_O:.o=.lo) $(LIB_NAME)
|
|
+
|
|
+gentoo_clean:
|
|
+ $(LIBTOOL) --mode=clean $(RM) $(ALL_O:.o=.lo) $(LIB_NAME) lua luac
|
|
+
|
|
+gentoo_all: $(LIB_NAME) $(LUA_T) lua_test $(LUAC_T)
|