You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-video/pitivi/files/pitivi-0.98.1-optional-test...

24 lines
742 B

Make tests optional
--- a/meson_options.txt 2016-09-19 23:35:54.944511834 +0200
+++ b/meson_options.txt 2016-09-19 23:36:10.693485976 +0200
@@ -1,2 +1,3 @@
option('enable-xunit', type : 'boolean', value : false)
option('disable-help', type : 'boolean', value : false)
+option('enable-tests', type : 'boolean', value : false)
--- a/meson.build 2017-09-03 22:52:39.681974053 +0200
+++ b/meson.build 2017-09-03 22:53:29.934556188 +0200
@@ -71,8 +71,10 @@
if not get_option('disable-help')
subdir('help')
endif
-subdir('tests')
-subdir('tests/validate-tests')
+if get_option('enable-tests')
+ subdir('tests')
+ subdir('tests/validate-tests')
+endif
archiver = find_program('git-archive-all', required : false)
if archiver.found()