You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/games-roguelike/stone-soup/files/gitless-1.patch

14 lines
639 B

--- /Makefile 2020-06-18 17:49:19.339016246 -0500
+++ /Makefile 2020-06-18 17:55:11.200700094 -0500
@@ -1181,9 +1181,8 @@
LANGUAGES = $(filter-out en, $(notdir $(wildcard dat/descript/??)))
SRC_PKG_BASE := stone_soup
-SRC_VERSION := $(shell git describe --tags $(MERGE_BASE) 2>/dev/null || cat util/release_ver)
+SRC_VERSION := $(shell cat util/release_ver)
MAJOR_VERSION = $(shell echo "$(SRC_VERSION)"|$(SED) -r 's/-.*//;s/^([^.]+\.[^.]+).*/\1/')
-RECENT_TAG := $(shell git describe --abbrev=0 --tags $(MERGE_BASE))
WINARCH := $(shell $(GXX) -dumpmachine | grep -q x64_64 && echo win64 || echo win32)
export SRC_VERSION