You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-arch/gcab/files/1.2-optional-vapi.patch

45 lines
1.4 KiB

From 5ac7272bba9635234fc08ab526b80a9f259d0fc6 Mon Sep 17 00:00:00 2001
From: Mart Raudsepp <leio@gentoo.org>
Date: Tue, 12 Feb 2019 11:44:10 +0200
Subject: [PATCH] build-sys: Support disabling vapi generation independent of
introspection
---
libgcab/meson.build | 12 +++++++-----
meson_options.txt | 1 +
2 files changed, 8 insertions(+), 5 deletions(-)
diff --git a/libgcab/meson.build b/libgcab/meson.build
index f939617..3c4ac68 100644
--- a/libgcab/meson.build
+++ b/libgcab/meson.build
@@ -93,9 +93,11 @@ if get_option('introspection')
],
install : true
)
- gnome.generate_vapi('libgcab-1.0',
- sources: gir[0],
- packages : ['gio-2.0'],
- install : true,
- )
+ if get_option('vapi')
+ gnome.generate_vapi('libgcab-1.0',
+ sources: gir[0],
+ packages : ['gio-2.0'],
+ install : true,
+ )
+ endif
endif
diff --git a/meson_options.txt b/meson_options.txt
index bbcbbea..b7ade3f 100644
--- a/meson_options.txt
+++ b/meson_options.txt
@@ -1,3 +1,4 @@
option('docs', type : 'boolean', value : true, description : 'enable developer documentation')
option('introspection', type : 'boolean', value : true, description : 'generate GObject Introspection data')
+option('vapi', type : 'boolean', value : true, description: 'generate Vala bindings (requires introspection)')
option('tests', type : 'boolean', value : true, description : 'enable tests')
--
2.17.0