You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-admin/collectd/files/collectd-5.1.0-libperl.patch

30 lines
935 B

diff --git a/configure.in b/configure.in
index 1cfc2fc..384c298 100644
--- a/configure.in
+++ b/configure.in
@@ -2944,11 +2944,13 @@ if test "x$with_libperl" = "xyes" \
then
SAVE_CFLAGS="$CFLAGS"
SAVE_LDFLAGS="$LDFLAGS"
+ SAVE_LIBS="$LIBS"
dnl ARCHFLAGS="" -> disable multi -arch on OSX (see Config_heavy.pl:fetch_string)
PERL_CFLAGS=`ARCHFLAGS="" $perl_interpreter -MExtUtils::Embed -e ccopts`
PERL_LDFLAGS=`ARCHFLAGS="" $perl_interpreter -MExtUtils::Embed -e ldopts`
CFLAGS="$CFLAGS $PERL_CFLAGS"
LDFLAGS="$LDFLAGS $PERL_LDFLAGS"
+ LIBS="$LIBS -lperl -lpthread"
AC_CACHE_CHECK([for libperl],
[c_cv_have_libperl],
@@ -2967,7 +2969,10 @@ dnl ARCHFLAGS="" -> disable multi -arch on OSX (see Config_heavy.pl:fetch_string
Nullsv);
]]),
[c_cv_have_libperl="yes"],
- [c_cv_have_libperl="no"]
+ [
+ c_cv_have_libperl="no"
+ LIBS="$SAVE_LIBS"
+ ]
)
)