You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-lang/gprolog/files/gprolog-1.4.2-links.patch

17 lines
562 B

diff -ur gprolog-1.4.2.orig/src/Makefile.in gprolog-1.4.2/src/Makefile.in
--- gprolog-1.4.2.orig/src/Makefile.in 2012-10-02 17:55:53.000000000 +0200
+++ gprolog-1.4.2/src/Makefile.in 2013-01-09 20:09:59.000000000 +0100
@@ -81,10 +81,10 @@
# --- Links --- #
-install-links: uninstall-links
+install-links:
if test $(LINKS_DIR) != none; then \
./mkinstalldirs $(LINKS_DIR); \
- (cd $(LINKS_DIR) ; $(LN_S) $(INSTALL_DIR)/bin/* .); \
+ (cd $(LINKS_DIR); for i in $(BIN_FILES); do $(LN_S) $(INSTALL_DIR)/bin/$$i .; done); \
fi
uninstall-links: