22 lines
759 B
Diff
22 lines
759 B
Diff
diff -burN photo-0.7.1.1-orig/CMakeLists.txt photo-0.7.1.1/CMakeLists.txt
|
|
--- photo-0.7.1.1-orig/CMakeLists.txt 2012-04-29 20:38:49.374650243 +0800
|
|
+++ photo-0.7.1.1/CMakeLists.txt 2012-04-29 21:00:03.237838770 +0800
|
|
@@ -28,7 +28,7 @@
|
|
if(UNIX)
|
|
|
|
# find xdg-desktop-menu and xdg-mime
|
|
- find_program(XDG-DESKTOP-MENU_EXECUTABLE xdg-desktop-menu)
|
|
+ #find_program(XDG-DESKTOP-MENU_EXECUTABLE xdg-desktop-menu)
|
|
|
|
# Set the install prefix to /usr/
|
|
SET(PRODUCT_INSTALL_PREFIX /usr)
|
|
@@ -41,7 +41,8 @@
|
|
|
|
# Install desktop file
|
|
INSTALL(
|
|
- CODE "execute_process(COMMAND ${XDG-DESKTOP-MENU_EXECUTABLE} install --novendor ${CMAKE_CURRENT_SOURCE_DIR}/photo.desktop)"
|
|
+ FILES photo.desktop
|
|
+ DESTINATION share/applications/
|
|
)
|
|
|
|
# And install all the icons
|