You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sci-mathematics/cryptominisat/files/cryptominisat-5.8.0-setup.p...

24 lines
678 B

index b3ab64af4..293eb1f80 100644
--- a/python/setup.py.in
+++ b/python/setup.py.in
@@ -27,7 +27,7 @@ import sys
import os
import platform
from distutils.core import setup, Extension
-from distutils import sysconfig
+import sysconfig
from distutils.cmd import Command
__PACKAGE_VERSION__ = "0.2.0"
@@ -59,8 +59,8 @@ def _init_posix(init):
Forces g++ instead of gcc on most systems
credits to eric jones (eric@enthought.com) (found at Google Groups)
"""
- def wrapper():
- init()
+ def wrapper(vars):
+ init(vars)
config_vars = sysconfig.get_config_vars() # by reference
if config_vars["MACHDEP"].startswith("sun"):