You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/games-puzzle/sdl-jewels/files/sdl-jewels-1.1.1-Makefile.p...

18 lines
488 B

--- SDL_jewels-1.1.1/Makefile.old 2010-11-13 00:46:47.196000082 +0000
+++ SDL_jewels-1.1.1/Makefile 2010-11-13 01:45:14.516000087 +0000
@@ -1,11 +1,12 @@
EXE = gljewel
-CFLAGS = -O2 -Wall $(shell sdl-config --cflags)
-LDFLAGS = $(shell sdl-config --libs) -lGL -lm
+CFLAGS += -Wall $(shell sdl-config --cflags)
+LIBS = $(shell sdl-config --libs) -lGL -lm
OBJS = $(EXE).o matrix.o sound.o
$(EXE): $(OBJS)
+ $(CC) $(LDFLAGS) $^ $(LIBS) -o $@
$(EXE).o: $(EXE).c matrix.h misc.h