You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-proxy/3proxy/files/3proxy-0.8.8-gentoo.patch

44 lines
1.4 KiB

--- a/Makefile.Linux 2016-12-16 20:24:53.809856430 +0200
+++ b/Makefile.Linux 2016-12-16 20:26:24.912859170 +0200
@@ -10,11 +10,11 @@
BUILDDIR =
CC = gcc
-CFLAGS = -g -O2 -c -pthread -DGETHOSTBYNAME_R -D_THREAD_SAFE -D_REENTRANT -DNOODBC -DWITH_STD_MALLOC -DFD_SETSIZE=4096 -DWITH_POLL
+CFLAGS += -c -pthread -DGETHOSTBYNAME_R -D_THREAD_SAFE -D_REENTRANT -DNOODBC -DWITH_STD_MALLOC -DFD_SETSIZE=4096 -DWITH_POLL
COUT = -o
LN = gcc
DCFLAGS = -fpic
-LDFLAGS = -O2 -pthread
+LDFLAGS += -pthread
DLFLAGS = -shared
DLSUFFICS = .ld.so
# -lpthreads may be reuqired on some platforms instead of -pthreads
@@ -39,12 +39,12 @@
include Makefile.inc
allplugins:
- @list='$(PLUGINS)'; for p in $$list; do cp Makefile Makefile.var plugins/$$p; cd plugins/$$p ; make ; cd ../.. ; done
+ @list='$(PLUGINS)'; for p in $$list; do cp Makefile Makefile.var plugins/$$p; cd plugins/$$p ; $(MAKE) ; cd ../.. ; done
DESTDIR =
-prefix = /usr/local
+prefix =
exec_prefix = $(prefix)
-man_prefix = $(prefix)/share
+man_prefix = $(prefix)/usr/share
INSTALL = /usr/bin/install
INSTALL_BIN = $(INSTALL) -m 755
--- a/src/stringtable.c 2016-12-16 20:24:53.811856430 +0200
+++ b/src/stringtable.c 2016-12-16 20:26:48.288859873 +0200
@@ -38,7 +38,7 @@
/* 24 */ NULL,
#ifndef TPROXY_CONF
#ifndef _WIN32
-/* 25 */ (unsigned char *)"/usr/local/etc/3proxy/3proxy.cfg",
+/* 25 */ (unsigned char *)"/etc/3proxy/3proxy.cfg",
#else
/* 25 */ (unsigned char *)"3proxy.cfg",
#endif