You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-libs/libsvgtiny/files/libsvgtiny-0.1.3-glibc2.20....

19 lines
650 B

--- libsvgtiny-0.1.3/Makefile
+++ libsvgtiny-0.1.3/Makefile
@@ -15,14 +15,8 @@
WARNFLAGS := -Wall -W -Wundef -Wpointer-arith -Wcast-align \
-Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes \
-Wmissing-declarations -Wnested-externs -pedantic
-# BeOS/Haiku/AmigaOS standard library headers create warnings
-ifneq ($(BUILD),i586-pc-haiku)
- ifneq ($(findstring amigaos,$(BUILD)),amigaos)
- WARNFLAGS := $(WARNFLAGS) -Werror
- endif
-endif
-CFLAGS := -D_BSD_SOURCE -I$(CURDIR)/include/ \
+CFLAGS := -D_DEFAULT_SOURCE -I$(CURDIR)/include/ \
-I$(CURDIR)/src $(WARNFLAGS) $(CFLAGS)
ifneq ($(GCCVER),2)
CFLAGS := $(CFLAGS) -std=c99