You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-admin/fetchlog/files/fetchlog-1.4-fix-build-syst...

31 lines
631 B

--- a/Makefile
+++ b/Makefile
@@ -23,8 +23,8 @@
### compiler
### gcc
-CC=gcc
-CFLAGS= -O -Werror -Wall -Wcast-qual -Wstrict-prototypes \
+CC ?= gcc
+CFLAGS += -Wall -Wcast-qual -Wstrict-prototypes \
-Wmissing-prototypes -Wmissing-declarations -Winline -Wcast-align
### cc
#CC=cc
@@ -72,7 +72,7 @@
# compiler stuff
# --------------
-CC_OPT= $(CFLAGS) -DFETCHLOG_VERSION_NO=\"$(FETCHLOG_VERSION)\" \
+CPPFLAGS += -DFETCHLOG_VERSION_NO=\"$(FETCHLOG_VERSION)\" \
$(HAS_MADVISE) $(HAS_REGEX)
# all
@@ -82,7 +82,6 @@
# fetchlog
# -------
fetchlog: fetchlog.c
- $(CC) $(CC_OPT) fetchlog.c -o fetchlog
# install