You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-emulation/cloud-init/files/cloud-init-0.7.8-gentooinit...

39 lines
1.1 KiB

diff --git a/setup.py b/setup.py
index bbadd7b..1578a3d 100755
--- a/setup.py
+++ b/setup.py
@@ -205,7 +207,7 @@ setuptools.setup(
author='Scott Moser',
author_email='scott.moser@canonical.com',
url='http://launchpad.net/cloud-init/',
- packages=setuptools.find_packages(exclude=['tests']),
+ packages=setuptools.find_packages(exclude=['tests.*', 'tests']),
scripts=['tools/cloud-init-per'],
license='GPLv3',
data_files=data_files,
diff --git a/sysvinit/gentoo/cloud-init b/sysvinit/gentoo/cloud-init
index 5afc0f2..531a715 100644
--- a/sysvinit/gentoo/cloud-init
+++ b/sysvinit/gentoo/cloud-init
@@ -2,6 +2,7 @@
# add depends for network, dns, fs etc
depend() {
after cloud-init-local
+ after net
before cloud-config
provide cloud-init
}
diff --git a/sysvinit/gentoo/cloud-init-local b/sysvinit/gentoo/cloud-init-local
index 9bd0b56..0f8cf65 100644
--- a/sysvinit/gentoo/cloud-init-local
+++ b/sysvinit/gentoo/cloud-init-local
@@ -2,7 +2,7 @@
depend() {
after localmount
- after netmount
+ before net
before cloud-init
provide cloud-init-local
}