You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-misc/spacenavd/files/spacenavd-0.5-destdir.patch

17 lines
649 B

diff -Npur spacenavd-0.5.orig/Makefile.in spacenavd-0.5/Makefile.in
--- spacenavd-0.5.orig/Makefile.in 2011-11-16 21:43:53.210859753 +0100
+++ spacenavd-0.5/Makefile.in 2011-11-16 21:45:36.386857932 +0100
@@ -24,9 +24,9 @@ clean:
.PHONY: install
install: $(bin)
- $(INSTALL) -d $(PREFIX)/bin
- $(INSTALL) -m 755 $(bin) $(PREFIX)/bin/$(bin)
- $(INSTALL) -m 755 $(srcdir)/$(ctl) $(PREFIX)/bin/$(ctl)
+ $(INSTALL) -d $(DESTDIR)$(PREFIX)/bin
+ $(INSTALL) -m 755 $(bin) $(DESTDIR)$(PREFIX)/bin/$(bin)
+ $(INSTALL) -m 755 $(srcdir)/$(ctl) $(DESTDIR)$(PREFIX)/bin/$(ctl)
cd $(srcdir) && ./setup_init --no-install
# [ -d /etc/hal/fdi/policy ] && \