You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-ml/num/files/num-1.3-cflags.patch

12 lines
409 B

--- a/src/Makefile 2020-05-21 18:54:31.176399032 +0200
+++ b/src/Makefile 2020-05-21 18:55:27.881498310 +0200
@@ -65,7 +65,7 @@
%.cmx: %.ml
$(OCAMLOPT) $(CAMLOPTFLAGS) -c $*.ml
%.$(O): %.c
- $(OCAMLC) -ccopt -DBNG_ARCH_$(BNG_ARCH) -c $*.c
+ $(OCAMLC) -ccopt "-DBNG_ARCH_$(BNG_ARCH) $(CFLAGS)" -c $*.c
# Legacy installation: files go into OCaml's stdlib directory; only META
# is installed via findlib