You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-games/openscenegraph/files/openscenegraph-3.6.5-cmake_...

15 lines
440 B

--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -771,10 +771,7 @@
FIND_PACKAGE(LIBLAS)
IF (NOT(OSG_USE_LOCAL_LUA_SOURCE))
- FIND_PACKAGE(Lua52)
- IF (NOT (LUA_LIBRARIES AND LUA_INCLUDE_DIR))
- FIND_PACKAGE(Lua51)
- ENDIF()
+ FIND_PACKAGE(Lua ${LUA_VERSION} EXACT)
ENDIF()
# V8 and Python plugins are tests for linking against these libraries but aren't functionality beyond this.