You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sys-process/criu/files/criu-2.8-automagic-libbsd.p...

18 lines
511 B

diff --git a/Makefile.config b/Makefile.config
index e0d49d2..d1b2b9d 100644
--- a/Makefile.config
+++ b/Makefile.config
@@ -2,10 +2,12 @@ include $(__nmk_dir)utils.mk
include $(__nmk_dir)msg.mk
include $(SRC_DIR)/scripts/feature-tests.mak
+ifeq ($(SETPROCTITLE),yes)
ifeq ($(call try-cc,$(FEATURE_TEST_LIBBSD_DEV),-lbsd),true)
LIBS_FEATURES += -lbsd
FEATURE_DEFINES += -DCONFIG_HAS_LIBBSD
endif
+endif
ifeq ($(call pkg-config-check,libselinux),y)
LIBS_FEATURES += -lselinux