You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-misc/binclock/files/binclock-1.5-Makefile.patch

23 lines
479 B

--- a/Makefile 2018-05-29 10:18:47.795059054 -0400
+++ b/Makefile 2018-05-29 10:21:37.126740904 -0400
@@ -18,8 +18,6 @@
# Boston, MA 02111-1307, USA
#
-CC = gcc
-CFLAGS = -O2 -Wall --pedantic
BIN = binclock
SRC = ./src/binclock.c
INSPATH = /usr/local/bin/
@@ -28,8 +26,8 @@
CONF = /etc/
all : $(MAINSRC)
- $(CC) $(CFLAGS) -o $(BIN) $(SRC)
- strip $(SOURCEPATH)$(BIN)
+ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -o $(BIN) $(SRC)
+ true $(SOURCEPATH)$(BIN)
install :