You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-shells/fish/files/fish-1.23.0-gentoo-alt.patch

79 lines
1.8 KiB

* Remove Darwin cruft, remove some Solaris misdetection crap, add
AM_ICONV instead of weird iconv check that not suprisingly fails on
Darwin.
--- configure.ac
+++ configure.ac
@@ -91,45 +91,6 @@
#
-# Detect directories which may contain additional headers, libraries
-# and commands. This needs to be done early - before Autoconf starts
-# to mess with CFLAGS and all the other environemnt variables.
-#
-# This mostly helps OS X users, since fink usually installs out of
-# tree and doesn't update CFLAGS.
-#
-
-for i in /usr/pkg /sw /opt /opt/local; do
-
- AC_MSG_CHECKING([for $i/include include directory])
- if test -d $i/include; then
- AC_MSG_RESULT(yes)
- CPPFLAGS="$CPPFLAGS -I$i/include/"
- CFLAGS="$CFLAGS -I$i/include/"
- else
- AC_MSG_RESULT(no)
- fi
-
- AC_MSG_CHECKING([for $i/lib library directory])
- if test -d $i/lib; then
- AC_MSG_RESULT(yes)
- LDFLAGS="$LDFLAGS -L$i/lib/ -R$i/lib/"
- else
- AC_MSG_RESULT(no)
- fi
-
- AC_MSG_CHECKING([for $i/bin command directory])
- if test -d $i/bin; then
- AC_MSG_RESULT(yes)
- optbindirs="$optbindirs $i/bin"
- else
- AC_MSG_RESULT(no)
- fi
-
-done
-
-
-#
# Tell autoconf to create config.h header
#
AC_CONFIG_HEADERS(config.h)
@@ -153,10 +114,7 @@
# Set up various programs needed for install
#
-# Here we look for c99 before cc as Sun Studio compiler supports c99
-# through the c99 binary.
-
-AC_PROG_CC([gcc c99 cc])
+AC_PROG_CC
AC_PROG_CPP
AC_PROG_INSTALL
@@ -520,9 +445,8 @@
AC_SEARCH_LIBS( gettext, intl,,)
fi
-
-AC_SEARCH_LIBS( iconv_open, iconv, , [AC_MSG_ERROR([Could not find an iconv implementation, needed to build fish])] )
-LIBS_FISH=$LIBS
-LIBS=$LIBS_COMMON
+AM_ICONV
+LIBS_FISH="$LIBS $LIBICONV"
+LIBS="$LIBS_COMMON $LIBICONV"
#
# Check for libraries needed by fish_indent.