You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-benchmarks/interbench/files/interbench-0.31-makefile.patch

17 lines
449 B

--- a/Makefile 2016-10-21 04:28:00.000000000 +0200
+++ b/Makefile 2018-11-01 16:56:36.000000000 +0100
@@ -1,8 +1,9 @@
-CC=gcc
-CFLAGS=-W -Wall -g -O2 -s -pipe
-LDFLAGS=-lrt -lm -pthread
+CC ?= gcc
+CFLAGS+=-W -Wall
+LDFLAGS+=-lrt -lm -pthread
-interbench: interbench.o hackbench.o -lm
+interbench: interbench.o hackbench.o
+ $(CC) $(CFLAGS) -o interbench interbench.o hackbench.o $(LDFLAGS)
interbench.o: interbench.c
hackbench.o: hackbench.c