You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/gnome-base/dconf/files/dconf-0.5.1-automagic-vala....

20 lines
467 B

--- configure.ac.orig 2010-11-06 16:24:36.000000000 +0100
+++ configure.ac 2010-11-06 16:24:19.000000000 +0100
@@ -12,7 +12,15 @@
# Check for programs
AC_PROG_CC
-AM_PROG_VALAC([0.9.5])
+
+AC_ARG_ENABLE(vala,
+ AC_HELP_STRING([--disable-vala],
+ [Disable vala support]))
+AM_CONDITIONAL(ENABLE_VALA, test "x$enable_vala" != "xno")
+
+if test "x$enable_vala" != "xno"; then
+ AM_PROG_VALAC([0.9.5])
+fi
# Introspection
GOBJECT_INTROSPECTION_CHECK([0.9.5])