You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-emulation/xen-tools/files/xen-4.2.0-jserver.patch

21 lines
900 B

diff -ur xen-4.2.0.orig/tools/tests/x86_emulator/Makefile xen-4.2.0/tools/tests/x86_emulator/Makefile
--- tools/tests/x86_emulator/Makefile 2012-09-17 18:21:19.000000000 +0800
+++ tools/tests/x86_emulator/Makefile 2012-11-24 05:06:24.355778737 +0800
@@ -14,13 +14,13 @@
.PHONY: blowfish.h
blowfish.h:
rm -f blowfish.bin
- XEN_TARGET_ARCH=x86_32 make -f blowfish.mk all
+ XEN_TARGET_ARCH=x86_32 $(MAKE) -f blowfish.mk all
(echo "static unsigned int blowfish32_code[] = {"; \
od -v -t x blowfish.bin | sed 's/^[0-9]* /0x/' | sed 's/ /, 0x/g' | sed 's/$$/,/';\
echo "};") >$@
rm -f blowfish.bin
ifeq ($(XEN_COMPILE_ARCH),x86_64)
- XEN_TARGET_ARCH=x86_64 make -f blowfish.mk all
+ XEN_TARGET_ARCH=x86_64 $(MAKE) -f blowfish.mk all
(echo "static unsigned int blowfish64_code[] = {"; \
od -v -t x blowfish.bin | sed 's/^[0-9]* /0x/' | sed 's/ /, 0x/g' | sed 's/$$/,/';\
echo "};") >>$@