You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-editors/xemacs/files/xemacs-21.5.34-ar.patch

75 lines
2.2 KiB

diff -r 3ca291c0f7e3 configure
--- a/configure Sun Jul 28 10:17:08 2019 +0100
+++ b/configure Sun Apr 19 18:46:45 2020 +0200
@@ -778,6 +778,5 @@
INSTALL_SCRIPT
INSTALL_PROGRAM
RANLIB
-AR
lib_gcc
ld
@@ -10296,47 +10307,6 @@
fi
-# Extract the first word of "ar", so it can be a program name with args.
-set dummy ar; ac_word=$2
-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
-$as_echo_n "checking for $ac_word... " >&6; }
-if ${ac_cv_prog_AR+:} false; then :
- $as_echo_n "(cached) " >&6
-else
- if test -n "$AR"; then
- ac_cv_prog_AR="$AR" # Let the user override the test.
-else
-as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
-for as_dir in $PATH
-do
- IFS=$as_save_IFS
- test -z "$as_dir" && as_dir=.
- for ac_exec_ext in '' $ac_executable_extensions; do
- if as_fn_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
- ac_cv_prog_AR="ar"
- $as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
- break 2
- fi
-done
- done
-IFS=$as_save_IFS
-
- test -z "$ac_cv_prog_AR" && ac_cv_prog_AR="not_found"
-fi
-fi
-AR=$ac_cv_prog_AR
-if test -n "$AR"; then
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $AR" >&5
-$as_echo "$AR" >&6; }
-else
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
-$as_echo "no" >&6; }
-fi
-
-
-if test "$AR" = "not_found"; then
- { echo "Error:" "ar not found -- is PATH set correctly?" >&2; exit 1; }
-fi
if test -n "$ac_tool_prefix"; then
# Extract the first word of "${ac_tool_prefix}ranlib", so it can be a program name with args.
set dummy ${ac_tool_prefix}ranlib; ac_word=$2
diff -r 3ca291c0f7e3 configure.ac
--- a/configure.ac Sun Jul 28 10:17:08 2019 +0100
+++ b/configure.ac Sun Apr 19 18:46:45 2020 +0200
@@ -2557,12 +2557,6 @@
dnl should make an entry in src/config.h, do not forget to add an
dnl #undef clause to src/config.h.in for autoconf to modify.
-dnl Sun likes to hide these utilities. Steve Baur asked that we make
-dnl the failure occur at configure time, not at use time.
-AC_CHECK_PROG(AR,ar,ar,not_found)
-if test "$AR" = "not_found"; then
- XE_DIE(["ar not found -- is PATH set correctly?"])
-fi
dnl These tests don't necessarily check that the program exists.
AC_PROG_RANLIB
AC_PROG_INSTALL